undefined

ThinkPHP5.0验证码使用

dd.gif

ThinkPHP5默认是没有验证码扩展的,需要使用composer去安装,可在composer.json文件的require里面添加"topthink/think-captcha":"1.*",然后composer update即可.

ThinkPHP5.0请使用1.*版本,ThinkPHP5.1则使用2.0版本。

thinkphp5.0内置验证码页面调用方式

<img src="{:captcha_src()}" onclick="this.src='{:captcha_src()}?'+Math.random();" />

将验证码通过表单提交到控制器方法执行以下代码测试

$code=input('captcha');//input为助手函数,获取提交数据
if(!captcha_check($code))//验证方法captcha_check()为助手函数
{
    echo "验证码错误!";
} else {
    echo "验证通过!";
}

第三方验证码类(composer安装)

use think\captcha\Captcha;

public function set_captcha(){
  $captcha = new Captcha();
  return $captcha->entry(1);
}

$captcha = new Captcha();
$res_captcha = $captcha->check($code, 1);

if(!$res_captcha){
  //验证失败
}

PS:如果'composer'更新很慢,可以使用这个镜像https://packagist.laravel-china.org,
编辑composer.json文件:

"repositories": {
    "packagist": {
        "type": "composer",
        "url": "https://packagist.laravel-china.org"
    }
}